===> The following configuration options are available for nsd3-3.2.21:
BIND8_STATS=off: BIND8-like NSTATS & XSTATS
CHECKING=off: Internal run-time checks
DOCS=on: Build and/or install documentation
IPV6=on: IPv6 protocol support
LARGEFILE=on: Largefile support
MAXIPS=off: Raise max-ips from 8 to 512
MINRESPSIZE=on: Minimial response sizing
MMAP=off: Use mmap instead of malloc (experimental)
NSEC3=on: NSEC3 support
NSEC3PREHASH=on: Full NSEC3 pre-hashing
ROOT_SERVER=off: Configure as a root server
RRL=off: Response Rate Limiting
ZONE_STATS=off: Per-zone BIND8 stats
===> Use 'make config' to modify these settings
**************************************************************************
* *
* NSD 3 is end-of-life. Please install NSD 4 if you want to use NSD. *
* For details, of the support commitments, see the mail at *
* http://www.nlnetlabs.nl/pipermail/nsd-users/2015-May/002100.html *
* and the project page <http://www.nlnetlabs.nl/projects/nsd/>. *
* *
**************************************************************************
**************************************************************************
* To run nsd from startup, add nsd_enable="YES" to your etc/rc.conf *
* *
* Take good care when using nsd commands, since they often need to *
* be executed as user dedicated to nsd, in order for the files it *
* touches or creates to have the proper permissions. *
* *
**************************************************************************
- update to 3.2.21
Changes:
Fix potential segfault in zone transfer corner case.
NSD 3 is end of life and support stops on May 20th, 2016.
BUG FIXES:
- Define _DEFAULT_SOURCE with _BSD_SOURCE for glibc 2.20 on Linux.
(Same as NSD 4.1.8).
- Fix #736: segfault during zone transfer. (Same as NSD 4.1.8).
PR: 207952
Submitted by: jaap@NLnetLabs.nl (maintainer)
MFH: 2016Q1
Warn users of the EOL and set expiration date.
Submitted by: mat
Approved by: Jaap Akkerhuis <jaap@NLnetLabs.nl> (maintainer)
Sponsored by: DK Hostmaster A/S
iupgrade to 3.2.19
FEATURES:
- Synthesize CNAMEs with same TTL as DNAME.
- RFC 7344: CDS and CDNSKEY (read in).
- hmac sha224, sha384 and sha512 support, patch from David Gwynne.
- max-interfaces raised to 32.
BUG FIXES:- Fix endian.h include for OpenBSD.
- Fix per-zone query class statistics.
- Fixes for wildcard addition and deletion.
- Fixes to zonec origin and b64 read (like in NSD 4.1.2).
- Fix tcp waiting list for zone transfers where the bind and connect calls
fail. (like in NSD 4.1.2)
- Removed compiler warnings from lex about unput and input functions.
NSD 3 is end-of-life. Please install an NSD 4 package if you want to
use NSD. Our support commitment lasts for about a year. For details,
see http://www.nlnetlabs.nl/pipermail/nsd-users/2015-May/002100.html .
PR: 200491
Submitted by: Jaap Akkerhuis <jaap@NLnetLabs.nl> (maintainer)
Reinstated PKGNAMESUFFIX which was missing
Added STAGING support
Other small changes to make portlint happy
PR: 186630
Submitted by: Jaap Akkerhuis <jaap@NLnetLabs.nl> (maintainer)
- Update to 3.2.17
- Add notice that support for nsd3 will stop in the future
FEATURES:
- Support for CAA RR type (RFC6844).
- EUI48 and EUI64 RR types (RFC7043) enabled by default.
BUG FIXES:
- Bugfix #509: USE_ZONE_STATS used initialised memory for statistics data.
- Bugfix #510: USE_ZONE_STATS use a different zone stats file per process.
- Bugfix #542: Match RRSIG TTL with SOA TTL in negative response.
PR: ports/186307
Submitted by: Jaap Akkerhuis <jaap@NLnetLabs.nl> (maintainer)
Please welcome NSD 4.0.0
For all new features, see
http://www.nlnetlabs.nl/svn/nsd/tags/NSD_4_0_0_REL/doc/NSD-4-features
This version replaces the nsdc control program with nsd-control.
This requires some manual setup with nsd-control-setup and editing
of the config files. nsd-control is incompatible with nsdc so when
that is used in scripts, these should be adapted.
NSD 3 is still supported as dns/nsd3.
PR: 183888
Submitted by: Jaap Akkerhuis <jaap@NLnetLabs.nl>