SEMI, Library of MIME feature for GNU Emacs for emacs20.
SEMI is a library to provide MIME feature for GNU Emacs. MIME is a
proposed internet standard for including content and headers other
than (ASCII) plain text in messages.
SEMI has the following features:
- MIME message viewer (mime-view-mode) (RFC 2045 .. 2049)
- MIME message composer (mime-edit-mode) (RFC 2045 .. 2049)
MIME message viewer and composer also support following features:
- filename handling by Content-Disposition field (RFC 1806)
- PGP/MIME security Multiparts (RFC 2015)
- application/pgp (draft-kazu-pgp-mime-00.txt; obsolete)
- text/richtext (RFC 1521; obsolete; preview only)
- text/enriched (RFC 1896)
- External method configuration by mailcap (RFC 1524)
Notice that this package does not contain MIME extender for any
MUAs. They are released as separated packages.
Ported by shige@FreeBSD.ORG
WWW: http://www.kanji.zinbun.kyoto-u.ac.jp/~tomo/elisp/SEMI/ (in Japanese)
Remove expired Emacs ports and the surrounding expired ports:
2007-08-19 chinese/mule-freewnn: emacs19 and related ports are obsolete; please
use a more recent version
2007-08-19 chinese/xemacs: emacs20 and related ports are obsolete; please use a
more recent version
2007-08-19 converters/mule-ucs-emacs20: emacs20 and related ports are obsolete;
please use a more recent version
2007-08-19 devel/eieio-emacs20: emacs20 and related ports are obsolete; please
use a more recent version
2007-08-19 editors/apel-emacs20: emacs20 and related ports are obsolete; please
use a more recent version
2007-08-19 editors/bitmap-emacs20: emacs20 and related ports are obsolete;
please use a more recent version
2007-08-19 editors/emacs19: emacs19 is obsolete; please use a more recent
version
2007-08-19 editors/emacs20: "editors/emacs is recommended instead for new
installations"
2007-08-19 editors/flim-emacs20: emacs20 and related ports are obsolete; please
use a more recent version
2007-08-19 editors/mule-common: emacs19 and related ports are obsolete; please
use a more recent version
2007-08-19 editors/mule: emacs19 and related ports are obsolete; please use a
more recent version
2007-08-19 editors/semi-emacs20: emacs20 and related ports are obsolete; please
use a more recent version
2007-08-19 editors/speedbar-emacs20: emacs20 and related ports are obsolete;
please use a more recent version
2007-08-19 irc/irchat-pj-emacs20: emacs20 and related ports are obsolete; please
use a more recent version
(Only the first 15 lines of the commit message are shown above )
- Fix possibility of "infinite make fork" when "Registering install for ..."
EMACS ports. [1]
- Allow building a port as root using an NFS-mounted /usr/ports if the
server maps root to a UID other than root. [2]
- Make 'BROKEN' and 'IGNORED' ports exit their "make install" with a fail
status rather than success. [3]
- Improve behavior when dealing with versioned dependencies. [4]
- Fix false positives in check-conflicts target. [5]
- Remove obsolete bzip2 code. [6]
(Only the first 15 lines of the commit message are shown above )
Reset MAINTAINER to ports@.
We cannot contact them for a long time.
Discussed with: hrs
Approved by: kiri(blanket), mita(blanket),
shige(blanket), taoka(blanket)
New master/slave scheme for semi-1.14.x ports. Update master port to emacs21.
Update slave ports to stub port: semi-emacs20, semi-xemacs21-mule. Does not
support semi-emacs(19) and semi-mule for semi-1.14.x or later. Change some
style.
Change PKGDIR from pkg/ to . Also fix places where ${PKGDIR} is spelled out
(many of which are ${PKGDIR}/MESSAGE -> ${PKGMESSAGE} type fixes that
shouldn't have been necessary) and the string "/pkg/" appear.