SEMI, Library of MIME feature for GNU Emacs for emacs20.
SEMI is a library to provide MIME feature for GNU Emacs. MIME is a
proposed internet standard for including content and headers other
than (ASCII) plain text in messages.
SEMI has the following features:
- MIME message viewer (mime-view-mode) (RFC 2045 .. 2049)
- MIME message composer (mime-edit-mode) (RFC 2045 .. 2049)
MIME message viewer and composer also support following features:
- filename handling by Content-Disposition field (RFC 1806)
- PGP/MIME security Multiparts (RFC 2015)
- application/pgp (draft-kazu-pgp-mime-00.txt; obsolete)
- text/richtext (RFC 1521; obsolete; preview only)
- text/enriched (RFC 1896)
- External method configuration by mailcap (RFC 1524)
Notice that this package does not contain MIME extender for any
MUAs. They are released as separated packages.
Ported by shige@FreeBSD.ORG
WWW: http://git.chise.org/elisp/semi/ (in Japanese)
===> The following configuration options are available for semi-xemacs21-mule-1.14.6_15:
DOCS=on: Build and/or install documentation
===> Use 'make config' to modify these settings
- Fix possibility of "infinite make fork" when "Registering install for ..."
EMACS ports. [1]
- Allow building a port as root using an NFS-mounted /usr/ports if the
server maps root to a UID other than root. [2]
- Make 'BROKEN' and 'IGNORED' ports exit their "make install" with a fail
status rather than success. [3]
- Improve behavior when dealing with versioned dependencies. [4]
- Fix false positives in check-conflicts target. [5]
- Remove obsolete bzip2 code. [6]
(Only the first 15 lines of the commit message are shown above )
- Fix dependency for flim-xemacs21-mule
- Sync dependencies for flim and semi-xemacs21-mule
for one style.
Reported by: kris via pointyhat
Discussed with: Andrey Slusar
Fix INDEX build:
- Get back editors/semi-xemacs21-mule and editors/flim-xemacs21-mule
untill a decision will be found.
- editors/flim: fix dependency. bump PORTREVISION.
- Remove a few of xemacs21-mule ports. They conflicts with
xemacs-mule-packages ports and better to be installed inside XEMACS.
It fixes ports/26192 submitted by Kang-min Liu <gugod_at_gugod.org>
in 2001 year.
Requested by: Andrey Slusar (xemacs21-mule and xemacs-mule-package ports)
Reset MAINTAINER to ports@.
We cannot contact them for a long time.
Discussed with: hrs
Approved by: kiri(blanket), mita(blanket),
shige(blanket), taoka(blanket)
New master/slave scheme for semi-1.14.x ports. Update master port to emacs21.
Update slave ports to stub port: semi-emacs20, semi-xemacs21-mule. Does not
support semi-emacs(19) and semi-mule for semi-1.14.x or later. Change some
style.
Change PKGDIR from pkg/ to . Also fix places where ${PKGDIR} is spelled out
(many of which are ${PKGDIR}/MESSAGE -> ${PKGMESSAGE} type fixes that
shouldn't have been necessary) and the string "/pkg/" appear.
Change dependency from texinfo.el to texinfmt.el. Texinfo.el is a major mode
elisp for editing Texinfo files. Texinfmt.el is for formatting Texinfo files
into Info files.