SEMI, Library of MIME feature for GNU Emacs for mule.
SEMI is a library to provide MIME feature for GNU Emacs. MIME is a
proposed internet standard for including content and headers other
than (ASCII) plain text in messages.
SEMI has the following features:
- MIME message viewer (mime-view-mode) (RFC 2045 .. 2049)
- MIME message composer (mime-edit-mode) (RFC 2045 .. 2049)
MIME message viewer and composer also support following features:
- filename handling by Content-Disposition field (RFC 1806)
- PGP/MIME security Multiparts (RFC 2015)
- application/pgp (draft-kazu-pgp-mime-00.txt; obsolete)
- text/richtext (RFC 1521; obsolete; preview only)
- text/enriched (RFC 1896)
- External method configuration by mailcap (RFC 1524)
Notice that this package does not contain MIME extender for any
MUAs. They are released as separated packages.
SEMI is installed the following directory tree:
${LOCALBASE}/share/mule/19.34/site-lisp/semi/
To use flim, put the following setup into your ~/.emacs:
(require 'apel-setupel)
(require 'flim-setupel)
(require 'semi-setupel)
Ported by shige@FreeBSD.ORG
- Fix possibility of "infinite make fork" when "Registering install for ..."
EMACS ports. [1]
- Allow building a port as root using an NFS-mounted /usr/ports if the
server maps root to a UID other than root. [2]
- Make 'BROKEN' and 'IGNORED' ports exit their "make install" with a fail
status rather than success. [3]
- Improve behavior when dealing with versioned dependencies. [4]
- Fix false positives in check-conflicts target. [5]
- Remove obsolete bzip2 code. [6]
(Only the first 15 lines of the commit message are shown above )
Reset MAINTAINER to ports@.
We cannot contact them for a long time.
Discussed with: hrs
Approved by: kiri(blanket), mita(blanket),
shige(blanket), taoka(blanket)
New master/slave scheme for flim-1.13.x(old version) ports.
Update master port to emacs21.
Update slave ports to stub port:
flim113-emacs20, flim113-mule, flim113-xemacs21-mule.
Remove slave ports:
flim113-emacs.
Add slave stub ports:
flim113-emacs19 for emacs-19.x ports.
Install el/elc files to version specific site-lisp directory.
Change some style.
New master/slave scheme for flim-1.13.x(old version) ports. Update master port
to emacs21. Update slave ports to stub port: flim113-emacs20,
flim113-mule, flim113-xemacs21-mule. Remove slave ports: flim113-emacs.
Add slave stub ports: flim113-emacs19 for emacs-19.x ports. Install el/elc
files to version specific site-lisp directory. Change some style.