This module (authres) is designed to provide support for RFC 5451/7001,
originally https://tools.ietf.org/html/rfc5451 (and then
https://tools.ietf.org/html/rfc7001 and https://tools.ietf.org/html/rfc7601) and
currently https://tools.ietf.org/html/rfc8601, processing in Python.
It also supports Authentication Results extensions:
- RFC 5617 DKIM/ADSP
- RFC 6008 DKIM signature identification (header.b)
- RFC 6212 Vouch By Reference (VBR)
- RFC 6577 Sender Policy Framework (SPF)
- RFC 7281 Authentication-Results Registration for S/MIME
- RFC 7293, The Require-Recipient-Valid-Since Header Field and SMTP Service
Extension, header field types
- RFC 7489 Domain-based Message Authentication, Reporting, and Conformance
(DMARC)
- RFC 8617 The Authenticated Received Chain (ARC) Protocol
NOTE: If this package has multiple flavors (see below), then use one of them instead of the name specified above. NOTE: This is a Python port. Instead of py311-authres listed in the above command, you can pick from the names under the Packages section.
*/*: Return to pool
I'll be away from keyboard soon and am not sure if I will return. So
return all ports that I currently maintain to pool hoping new
volunteers take care of them.
mail/py-authres: Revert "Release maintainership"
This reverts commit 84f99d2d56f77d09753a5277fe1ac6ede901d41a.
I released maintainership of this port because I thought I didn't use
it any more. But it was misunderstanding. So take back maintainership.
all: remove explicit versions in USES=python for "3.x+"
The logic in USES=python will automatically convert this to 3.8+ by
itself.
Adjust two ports that only had Python 3.7 mentioned but build fine
on Python 3.8 too.
finance/quickfix: mark BROKEN with PYTHON
libtool: compile: c++ -DHAVE_CONFIG_H -I. -I../.. -I -I. -I.. -I../.. -I../C++
-DLIBICONV_PLUG -DPYTHON_MAJOR_VERSION=3 -Wno-unused-variable
-Wno-maybe-uninitialized -O2 -pipe -DLIBICONV_PLUG -fstack-protector-strong
-fno-strict-aliasing -DLIBICONV_PLUG -Wall -ansi
-Wno-unused-command-line-argument -Wpointer-arith -Wwrite-strings
-Wno-overloaded-virtual -Wno-deprecated-declarations -Wno-deprecated -std=c++0x
-MT _quickfix_la-QuickfixPython.lo -MD -MP -MF
.deps/_quickfix_la-QuickfixPython.Tpo -c QuickfixPython.cpp -fPIC -DPIC -o
.libs/_quickfix_la-QuickfixPython.o
warning: unknown warning option '-Wno-maybe-uninitialized'; did you mean
'-Wno-uninitialized'? [-Wunknown-warning-option]
QuickfixPython.cpp:175:11: fatal error: 'Python.h' file not found
^~~~~~~~~~
1 warning and 1 error generated.
Reviewed by: portmgr, vishwin, yuri
Differential Revision: <https://reviews.freebsd.org/D40568>
Remove WWW entries moved into port Makefiles
Commit b7f05445c00f has added WWW entries to port Makefiles based on
WWW: lines in pkg-descr files.
This commit removes the WWW: lines of moved-over URLs from these
pkg-descr files.
Approved by: portmgr (tcberner)
Add WWW entries to port Makefiles
It has been common practice to have one or more URLs at the end of the
ports' pkg-descr files, one per line and prefixed with "WWW:". These
URLs should point at a project website or other relevant resources.
Access to these URLs required processing of the pkg-descr files, and
they have often become stale over time. If more than one such URL was
present in a pkg-descr file, only the first one was tarnsfered into
the port INDEX, but for many ports only the last line did contain the
port specific URL to further information.
There have been several proposals to make a project URL available as
a macro in the ports' Makefiles, over time.
(Only the first 15 lines of the commit message are shown above )
mail: remove 'Created by' lines
A big Thank You to the original contributors of these ports:
* <ashish@FreeBSD.org>
* Aaron Dalton <aaron@FreeBSD.org>
* Adam David <adam@FreeBSD.org>
* Adam McDougall <mcdouga9@egr.msu.edu>
* Adam Weinberger <adamw@FreeBSD.org>
* Ade Lovett <ade@FreeBSD.org>
* Akinori MUSHA aka knu <knu@idaemons.org>
* Alex Deiter <tiamat@komi.mts.ru>
* Alex Dupre <ale@FreeBSD.org>
* Alex Dupre <sysadmin@alexdupre.com>
* Alex Perel <veers@disturbed.net>
(Only the first 15 lines of the commit message are shown above )
mail/py-authres: Update to 1.0.0
- Added initial experimental support for ARC results
- Swith to sematic versioning scheme and only set version in setup.py and
__init__
PR: 220726
Submitted by: Yasuhiro KIMURA <yasu@utahime.org> (maintainer)
Approved by: garga (mentor, implicit)
mail/py-authres: Move MASTER_SITES to CHEESESHOP
Using CHEESESHOP (PyPI) is recommended as the default
MASTER_SITES for Python packages where the distribution
files (sdist) are available there, unless there are
compelling reasons to use an alternative source such
as GitHub, for example if test, data or other important
files are not included due to incorrect packaging or otherwise.
PR: 220257
Reported by: koobs
Reviewed by: koobs, garga
Approved by: garga (mentor), yasu@utahime.org (maintainer)
Differential Revision: D11343