NOTE: If this package has multiple flavors (see below), then use one of them instead of the name specified above. NOTE: This is a Python port. Instead of py312-slepc4py listed in the above command, you can pick from the names under the Packages section.
python.mk: rename PYTHON_EXT_SUFFIX to PYTHON_TAG, document, etc
EXT_SUFFIX, according to PEP 3149, refers to the full tag and
extension for compiled extension module objects, eg .cpython-311.so,
.cpython-313t.so, etc. We do not use the correct semantic meaning,
and this usage becomes ambiguous and confusing when tags do not
match between bytecode and compiled extension module objects.
Rename our PYTHON_EXT_SUFFIX to PYTHON_TAG to align with PEP 3147's
specification of a magic tag, which consists of implementation name
and shorthand version only. This is meant for bytecode and other
files containing this tag in their filename that do not depend on
a specific Python ABI for the same version. Chase all existing
consumers.
(Only the first 15 lines of the commit message are shown above )
Mk/Uses/python.mk: Introduce USE_PYTHON=cython3{,_run,_test}
- Update USE_PYTHON=cython{,_run,_test}
- Convert all cython3 occurrence to USE_PYTHON=cython3*
- While I'm here, fix incorrect usage of combining cython3 in BUILD_DEPENDS and
USE_PYTHON=cython
It is added to simplify the future transition from Cython 0.29 to 3.
The minimal version is set to 3.0.12 because it is required by
devel/py-propcache.
The upper bound of version is set to 3.1 because it is limited by multiple
ports.
python: bump all USE_PYTHON=distutils consumers after RUN_DEPENDS removal
Any missed ports, feel free to bump.
Any ports that need setuptools at runtime can have the devel/py-setuptools
manually added back to RUN_DEPENDS, but understand that this practice
is deprecated; see CHANGES for details.
all: remove explicit versions in USES=python for "3.x+"
The logic in USES=python will automatically convert this to 3.8+ by
itself.
Adjust two ports that only had Python 3.7 mentioned but build fine
on Python 3.8 too.
finance/quickfix: mark BROKEN with PYTHON
libtool: compile: c++ -DHAVE_CONFIG_H -I. -I../.. -I -I. -I.. -I../.. -I../C++
-DLIBICONV_PLUG -DPYTHON_MAJOR_VERSION=3 -Wno-unused-variable
-Wno-maybe-uninitialized -O2 -pipe -DLIBICONV_PLUG -fstack-protector-strong
-fno-strict-aliasing -DLIBICONV_PLUG -Wall -ansi
-Wno-unused-command-line-argument -Wpointer-arith -Wwrite-strings
-Wno-overloaded-virtual -Wno-deprecated-declarations -Wno-deprecated -std=c++0x
-MT _quickfix_la-QuickfixPython.lo -MD -MP -MF
.deps/_quickfix_la-QuickfixPython.Tpo -c QuickfixPython.cpp -fPIC -DPIC -o
.libs/_quickfix_la-QuickfixPython.o
warning: unknown warning option '-Wno-maybe-uninitialized'; did you mean
'-Wno-uninitialized'? [-Wunknown-warning-option]
QuickfixPython.cpp:175:11: fatal error: 'Python.h' file not found
^~~~~~~~~~
1 warning and 1 error generated.
Reviewed by: portmgr, vishwin, yuri
Differential Revision: <https://reviews.freebsd.org/D40568>
Remove expired ports:
2020-12-12 textproc/py-hypua2jamo: Uses deprecated version of python
2020-12-12 devel/py-delfick_error: Uses deprecated version of python
2020-12-12 devel/py-fusefs: Uses deprecated version of python
2020-08-15 devel/py-noseofyeti: Uses deprecated version of python
2020-12-29 databases/py-bsddb: Uses deprecated version of python
2020-12-29 www/py-webhelpers: Uses deprecated version of python
2020-12-29 security/py-pyptlib: Uses deprecated version of python
2020-12-29 japanese/py-zinnia: Uses deprecated version of python
2020-12-29 math/slepc: Broken, uses deprecated version of python
2020-12-29 www/py-pastescript: Uses deprecated version of python
2020-12-29 databases/ldb14: Uses deprecated version of python
2020-12-29 math/py-slepc4py: Depends on broken and expiring math/slepc
2020-12-29 multimedia/py-kaa-base: Uses deprecated version of python
2020-12-29 devel/py-ydbf: Uses deprecated version of python
2020-12-29 devel/py-SymbolType: Uses deprecated version of python
Bump PORTREVISION for ports depending on the canonical version of GCC
as defined in Mk/bsd.default-versions.mk which has moved from GCC 8.3
to GCC 9.1 under most circumstances now after revision 507371.
This includes ports
- with USE_GCC=yes or USE_GCC=any,
- with USES=fortran,
- using Mk/bsd.octave.mk which in turn features USES=fortran, and
- with USES=compiler specifying openmp, nestedfct, c11, c++0x, c++11-lang,
c++11-lib, c++14-lang, c++17-lang, or gcc-c++11-lib
plus, everything INDEX-11 shows with a dependency on lang/gcc9 now.
PR: 238330
Related to revision 499061 bump ports with USES=fortran to have them
benefit from the improved situation where libgcc_s is only used when
absolutely necessary.
Suggested by: tijl
Bump PORTREVISION for ports depending on the canonical version of GCC
defined via Mk/bsd.default-versions.mk which has moved from GCC 7.4 t
GCC 8.2 under most circumstances.
This includes ports
- with USE_GCC=yes or USE_GCC=any,
- with USES=fortran,
- using Mk/bsd.octave.mk which in turn features USES=fortran, and
- with USES=compiler specifying openmp, nestedfct, c11, c++0x, c++11-lang,
c++11-lib, c++14-lang, c++17-lang, or gcc-c++11-lib
plus, as a double check, everything INDEX-11 showed depending on lang/gcc7.
PR: 231590
science/PETSc: Update 3.9.4->3.10.1; math/py-petsc4py: Update 3.9.1->3.10.0;
math/slepc: Update 3.9.2->3.10.0; math/py-slepc4py: Update 3.9.0->3.10.0
Bump math/sundials and math/petiga.
On commit because they depend on each other and don't build unless versions
match.
Change 10 ports from net/mpich2 to net/mpich
mpich2 is the obsolete version 2.x, mpich is at the current version 3.x
science/triqs science/PETSc math/py-slepc4py math/slepc math/py-petsc4py
math/petiga math/sundials cad/elmerfem math/blocksolve95 math/spooles
Bump PORTREVISION for ports depending on the canonical version of GCC
in the ports tree (via Mk/bsd.default-versions.mk and lang/gcc) which
has now moved from GCC 6 to GCC 7 by default.
This includes ports
- featuring USE_GCC=yes or USE_GCC=any,
- featuring USES=fortran,
- using Mk/bsd.octave.mk which in turn features USES=fortran, and those
- with USES=compiler specifying one of openmp, nestedfct, c11, c++0x,
c++11-lib, c++11-lang, c++14-lang, c++17-lang, or gcc-c++11-lib.
PR: 222542