This is a pure-ruby library for decoding and encoding vCard and
iCalendar data ("personal information") called vPim.
vCard (RFC 2426) is a format for personal information, see Vpim::Vcard
and Vpim::Maker::Vcard.
iCalendar (RFC 2445) is a format for calendar related information, see
Vpim::Icalendar.
vCard and iCalendar support is built on top of an implementation of
the MIME Content-Type for Directory Information (RFC 2425). The basic
RFC 2425 format is implemented by Vpim::DirectoryInfo and
Vpim::DirectoryInfo::Field.
WWW: http://rubyforge.org/projects/vpim
many ruby/rubygem ports: death of rubyforge.org
rubyforge.org shutdown on May 15, 2014. This commit accounts for that by doing
several things:
- Deprecate ruby that had only rubyforge.org as MASTER_SITES (and so are now
only fetchable via our cache)
- Deprecate ports that depend on those
- Update the WWW pkg-descr line that points to rubyforge.org for rubygem ports
(which are still fetchable from rubygems.org)
The next step will be to remove rubyforge.org from bsd.sites.mk, after these
deprecated ports are deleted.
Phabric: D591
With hat: ruby
Approved by: portmgr (because of committing to unstaged graphics/mingplot port)