SEND is the implementation of RFC3971 Secure Neighbor Discovery
(SEND). SEND cryptographically secures the IPv6 neighbor discovery
protocol, countering the threats discussed in RFC3756 (IPv6 Neighbor
Discovery (ND) Trust Models and Threats).
The implementation is a new version of DoCoMo's SEND (send_0.2) that
was implemented completely in user space. Novelty in send_0.3 is the
native SEND API that avoids the need for the use of netgraph and BPF,
which makes send_0.3 portable over different BSD platforms and
significantlly more efficient.
Also included in the distribution are implementations of RFC3972
Cryptographically Generated Addresses (CGAs) and RFC3779 X.509
Extensions for IP Addresses and AS Identifiers.
===> The following configuration options are available for send-0.3_4:
DOCS=on: Build and/or install documentation
===> Use 'make config' to modify these settings
*/*: llvm15 build fixes
llvm15 was also merged into 13.2-STABLE effective from OSVERSION
1302505. Fix the ports that failed to build with llvm15.
Approved by: portmgr (blanket)
net-mgmt/send: Mark DEPRECATED
- Implementation is based on
- RFC3971 which has been updated by RFC6494, RFC6495, RFC6980
- Set EXPIRATION_DATE to 2023-06-02
- Mark BROKEN_SSL as it fails to build with OpenSSL 3.0.0 and later
with error: unknown type name 'IPAddressRange'
Approved by: portmgr (blanket)
net-mgmt/send: fix build with -fno-common
Declare two external variables as extern properly.
This unbreaks the build on FreeBSD 13+.
While we are at it, add missing USES=ncurses.
Approved by: portmgr (build fix blanket)
For some ports under `net*' categories: remove redundant PKGMESSAGE
assignment, which is set appropriately by the b.p.m when `pkg-message'
appears on the SUB_FILES list.
MASTER_SITES cleanup.
- Replace ${MASTER_SITE_FOO} with FOO.
- Merge MASTER_SITE_SUBDIR into MASTER_SITES when possible. (This means 99.9%
of the time.)
- Remove occurrences of MASTER_SITE_LOCAL when no subdirectory was present and
no hint of what it should be was present.
- Fix some logic.
- And generally, make things more simple and easy to understand.
While there, add magic values to the FESTIVAL, GENTOO, GIMP, GNUPG, QT and
SAMBA macros.
Also, replace some EXTRACT_SUFX occurences with USES=tar:*.
Checked by: make fetch-urlall-list
With hat: portmgr
Sponsored by: Absolight
Remove expired ports:
2014-06-30 www/trac-TracDuplicates: Broken for more than 5 months
2014-06-30 mail/hotwayd: Protocol changed, software unusable
2014-06-30 mail/ilohamail-devel: Upstream disappeared
2014-06-30 games/tyrquake: Broken for more than 5 months
2014-06-30 net/gkrellmqst: GKrellM 1.X is no longer being developed, consider
using 2.X.
2014-06-30 security/p5-Jifty-Plugin-OpenID: Broken for more than 5 months
2014-06-30 games/sumwars: Broken for more than 5 months
2014-06-30 audio/ruby-esound: Broken for more than 5 months
2014-06-30 x11-toolkits/py-pyqwt: Broken for more than 5 months
2014-06-30 net-im/ysm: Broken for more than 5 months
2014-06-30 net-mgmt/send: Broken for more than 5 months
2014-06-30 net/p5-Jifty-Plugin-Authentication-Ldap: Broken for more than 5
months
2014-06-30 net-p2p/bittyrant: Broken for more than 5 months
2014-06-30 sysutils/gkrellm: GKrellM 1.X is no longer being developed, consider
using 2.X.
2014-06-30 audio/gkrellmms: GKrellM 1.X is no longer being developed, consider
using 2.X.
2014-06-30 audio/gkrellmvolume: GKrellM 1.X is no longer being developed,
consider using 2.X.
2014-06-30 misc/gkrellmlaunch: GKrellM 1.X is no longer being developed,
consider using 2.X.
2014-06-30 misc/gkrellmfmonitor: GKrellM 1.X is no longer being developed,
consider using 2.X.
2014-06-30 misc/gkrellshoot: GKrellM 1.X is no longer being developed, consider
using 2.X.
2014-06-30 polish/sms2: sms2 is no longer being developed, consider using
alternative software.
2014-06-30 x11-toolkits/py-wmdockapps: Crufty and nothing depends on this
2014-06-30 audio/tagger: Ancient, unmaintained
2014-06-30 www/mod_wsgi2: No longer supported, please use www/mod_wsgi3 instead
2014-06-30 security/botan: Botan 1.8 have known bugs and is no longer supported
upstream, migrate to security/botan110
Mark as broken:
usr/bin/ld: i386 architecture of input file `sendd.o' is incompatible with
i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `addr.o' is incompatible with
i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `cert.o' is incompatible with
i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `cga.o' is incompatible with
i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `config.o' is incompatible with
i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `cpa.o' is incompatible with
i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `cps.o' is incompatible with
i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `ctl.o' is incompatible with
i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `net.o' is incompatible with
i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `openssl.o' is incompatible with
i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `opt.o' is incompatible with
i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `params.o' is incompatible with
i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `proto.o' is incompatible with
i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `proto_nonce.o' is incompatible
with i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `proto_sig.o' is incompatible with
i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `proto_timestamp.o' is incompatible
with i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `ra.o' is incompatible with
i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `sigmeth.o' is incompatible with
i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `sig_rfc3971.o' is incompatible
with i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `console.o' is incompatible with
i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `dbg.o' is incompatible with
i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `params_gram.o' is incompatible
with i386:x86-64 output
/usr/bin/ld: i386 architecture of input file `params_lex.o' is incompatible with
i386:x86-64 output
In the rc.d scripts, change assignments to rcvar to use the
literal name_enable wherever possible, and ${name}_enable
when it's not, to prepare for the demise of set_rcvar().
In cases where I had to hand-edit unusual instances also
modify formatting slightly to be more uniform (and in
some cases, correct). This includes adding some $FreeBSD$
tags, and most importantly moving rcvar= to right after
name= so it's clear that one is derived from the other.
[NEW PORT] net-mgmt/send: Secure Neighbor Discovery implementation for IPv6
DoCoMo's Open Source SEND project provides an implementation of
RFC3971 Secure Neighbor Discovery (SEND). SEND cryptographically
secures the IPv6 neighbor discovery protocol, countering the threats
discussed in RFC3756 (IPv6 Neighbor Discovery (ND) Trust Models and
Threats).
DoCoMo's SEND is implemented completely in user space, so it is
portable and lends itself to experimentation. It currently runs on
Linux (tested on 2.6 kernels) and FreeBSD (tested on 5.4).
Also included in the distribution are implementations of RFC3972
Cryptographically Generated Addresses (CGAs) and RFC3779 X.509
Extensions for IP Addresses and AS Identifiers.
WWW: http://www.docomolabs-usa.com/lab_osrc_guide.html
Doesn't work on FreeBSD > 6.x though. Hopefully the submitter will
submit patches for it now it is commited.
PR: ports/116540
Submitted by: Janos Mohacsi <janos.mohacsi@bsd.hu>