WIDE-DHCPv6 is an open-source implementation of Dynamic Host
Configuration Protocol for IPv6 (DHCPv6), originally developed
by the KAME project.
The implementation mainly conforms to the following standards:
- RFC3315: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
- RFC3319: DHCPv6 Options for Session Initiation Protocol (SIP) Servers
- RFC3633: IPv6 Prefix Options for DHCP
- RFC3646: DNS Configuration options for DHCPv6
- RFC3898: Network Information Service (NIS) Configuration Options for DHCPv6
- RFC4075: Simple Network Time Protocol (SNTP) Configuration Option for DHCPv6
- RFC4242: Information Refresh Time Option for DHCPv6
- RFC4280: DHCP Options for Broadcast and Multicast Control Servers
Note that the current implementation does not support temporary
IPv6 address allocation by DHCPv6, and there is no plan to
implement that feature at the moment.
===> The following configuration options are available for dhcp6-20080615.2_4:
DOCS=on: Build and/or install documentation
===> Use 'make config' to modify these settings
*/*: Update WWW to use HTTPS for sourceforge.net projects
Homepage link is permanent redirected to its HTTPS counterpart
Issue reported by repology : https://repology.org/repository/freebsd/problems
Approved by: portmgr (blanket)
PR: 274888
Remove WWW entries moved into port Makefiles
Commit b7f05445c00f has added WWW entries to port Makefiles based on
WWW: lines in pkg-descr files.
This commit removes the WWW: lines of moved-over URLs from these
pkg-descr files.
Approved by: portmgr (tcberner)
Add WWW entries to port Makefiles
It has been common practice to have one or more URLs at the end of the
ports' pkg-descr files, one per line and prefixed with "WWW:". These
URLs should point at a project website or other relevant resources.
Access to these URLs required processing of the pkg-descr files, and
they have often become stale over time. If more than one such URL was
present in a pkg-descr file, only the first one was tarnsfered into
the port INDEX, but for many ports only the last line did contain the
port specific URL to further information.
There have been several proposals to make a project URL available as
a macro in the ports' Makefiles, over time.
(Only the first 15 lines of the commit message are shown above )
net: remove 'Created by' lines
A big Thank You to the original contributors of these ports:
* <ports@c0decafe.net>
* Aaron Dalton <aaron@FreeBSD.org>
* Aaron Straup Cope <ascope@cpan.org>
* Aaron Zauner <az_mail@gmx.at>
* Adam Jette <jettea46@yahoo.com>
* Adam Weinberger <adamw@FreeBSD.org>
* Alan Eldridge <alane@geeksrus.net>
* Alex Bakhtin <Alex.Bakhtin@gmail.com>
* Alex Deiter <Alex.Deiter@Gmail.COM>
* Alex Dupre <ale@FreeBSD.org>
* Alex Dupre <sysadmin@alexdupre.com>
(Only the first 15 lines of the commit message are shown above )
net/dhcp6: Fix rcorder.
We want netif be started before dhcp6c which properly initializes
the interfaces, and we want dhcp6s to start later and after dhcp6c.
Differential Revision: https://reviews.freebsd.org/D26655
net/dhcp6: several fixes
- rcorder incorrect (Circular dependency on provision `DAEMON')
- command_flags do not need to be referenced inside of the command_args
- dhcp6s exits because of shutdown on non-connected UDP socket
PR: 216673, 217452, 228994
Submitted by: tdb, Andrey Pevnev <apevnev@me.com>, leres, Dries Michiels
<driesm.michiels@gmail.com>
Approved by: hrs (maintainer timeout)
Differential Revision: D16994
Apparently starting with version 20080615.2 dhcp6c refuses
to run without a dhcp6cctlkey file. Use openssl to generate
one from the rc.d script when it is missing.
PR: 229400
Reviewed by: ler (mentor)
Approved by: maintainer timeout (6 weeks), ler (mentor)
Differential Revision: https://reviews.freebsd.org/D16739
Update to 20080615.2. Changes include:
- Remove the PID file just before dhcp6c actually exits.
- Set a DHCPv6 state keyword to an environment variable "REASON" which
is passed to the client script when receiving a REPLY message instead of
"NBI".
- Add a signal handler for SIGUSR1 to forcibly exit without
releasing the obtained addresses.
- Add a new script event "EXIT", which is invoked when dhcp6c exits.
Reference: https://github.com/hrs-allbsd/wide-dhcpv6/pull/5
- Use another github repo to maintain the patches since the original
upstream is no longer actively maintained.
- Add -n flag to prevent Release message from being sent when dhcp6c stops.[*]
- Add more log for DHCP messages.[*]
Based on work by: marjohn56 (martin@queens-park.com)
Revert a patch to avoid na_ifaddrconf() when renewing an IA-NA address.
This patch prevented from updating the address lifetime.
Reported by: garga and pfSense Bug #5955
Add a patch to make it possible to increase verbosity even in daemon mode
Approved by: hrs (maintainer)
Obtained from: pfSense
Sponsored by: Rubicon Communications (Netgate)
Differential Revision: https://reviews.freebsd.org/D5105
Add patches to fix the following bugs:
- Fix renewal of IA_NA [*]
- Update ifid on interface restart, it may have changed [*]
- Remove unnecessary PF_ROUTE socket. [*]
- Fix wrong length used in memset().
Obtained from: Debian/Ubuntu/Fedora/Red Hat packages via OpenBSD [*]
Suggested by: Brad Smith [*]
- Set FD_CLOEXEC on sockets to prevent leakage.
- Call a configuration script after addresses and prefixes are set
on an interface.
- Do not call rc.d scripts during uninstallation.
Submitted by: garga
PR: 204462
Obtained from: pfSense
Sponsored by: Rubicon Communications (Netgate)
In the rc.d scripts, change assignments to rcvar to use the
literal name_enable wherever possible, and ${name}_enable
when it's not, to prepare for the demise of set_rcvar().
In cases where I had to hand-edit unusual instances also
modify formatting slightly to be more uniform (and in
some cases, correct). This includes adding some $FreeBSD$
tags, and most importantly moving rcvar= to right after
name= so it's clear that one is derived from the other.
Fix a few "bad example" problems in the rc.d scripts that have been
propogated by copy and paste.
1. Primarily the "empty variable" default assignment, which is mostly
${name}_flags="", but fix a few others as well.
2. Where they are not already documented, add the existence of the _flags
(or other deleted empties) option to the comments, and in some cases add
comments from scratch.
3. Replace things that look like:
prefix=%%PREFIX%%
command=${prefix}/sbin/foo
to just use %%PREFIX%%. In many cases the $prefix variable is only used
once, and in some cases it is not used at all.
4. In a few cases remove ${name}_flags from command_args
5. Remove a long-stale comment about putting the port's rc.d script in
/etc/rc.d (which is no longer necessary).
No PORTREVISION bumps because all of these changes are noops.
Remove the FreeBSD KEYWORD from all rc.d scripts where it appears.
We have not checked for this KEYWORD for a long time now, so this
is a complete noop, and thus no PORTREVISION bump. Removing it at
this point is mostly for pedantic reasons, and partly to avoid
perpetuating this anachronism by copy and paste to future scripts.
- updated to the latest package
- now this package is provided from sourceforge.net, instead of kame.net
- now suz takes over the maintainership from sumikawa
Reviewed by: sumikawa
kame-dhcp6 is an open-source implementation of Dynamic Host
Configuration Protocol for IPv6 (DHCPv6) developed by the KAME
project.
The implementation mainly conforms to the following standards:
- RFC3315: Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
- RFC3319: Dynamic Host Configuration Protocol (DHCPv6) Options
for Session Initiation Protocol (SIP) Servers
- RFC3633: IPv6 Prefix Options for Dynamic Host Configuration
Protocol (DHCP)
- RFC3646: DNS Configuration options for Dynamic Host
Configuration Protocol for IPv6 (DHCPv6)
Note that the current implementation does not support IPv6 address
allocation by DHCPv6, and there is no plan to implement that feature
at the moment. The main purpose of this implementation is to provide
a way of IPv6 prefix delegation (RFC3633) and to provide some
"stateless" configuration information such as DNS recursive server
addresses.
WWW: http://www.kame.net/