oRTP - Real-time Transport Protocol library
Features:
* Written in C, works under Linux (and probably any Unix) and Windows
* Implement the RFC3550 (RTP) with a easy to use API with high and low level
access
* Includes support for multiples profiles, AV profile (RFC3551) being the
one by default
* Includes a packet scheduler for to send and recv packet "on time",
according to their timestamp. Scheduling is optionnal, rtp sessions can
remain not scheduled
* Supports mutiplexing IO, so that hundreds of RTP sessions can be scheduled
by a single thread
* Features an adaptive jitter algorithm for a receiver to adapt to the
clockrate of the sender
* Supports part of RFC2833 for telephone events over RTP
* The API is well documented using doxygen
* Licensed under the Lesser Gnu Public License
* RTCP messages sent periodically since 0.7.0 (compound packet including
sender report or receiver report + SDES)
* Includes an API to parse incoming RTCP packets
bsd.sites.mk: Update all ports using USE_GITLAB
Replace GL_COMMIT by GL_TAGNAME in all ports. The new GL_TAGNAME is
backwards-compatible (accepting any commit hash as before), but also
understands an actual tag name. Moving to tag names where appropriate is
left to individual ports' maintainers.
Approved by: portmgr (tcberner, mentor)
Differential Revision: https://reviews.freebsd.org/D37077
Remove WWW entries moved into port Makefiles
Commit b7f05445c00f has added WWW entries to port Makefiles based on
WWW: lines in pkg-descr files.
This commit removes the WWW: lines of moved-over URLs from these
pkg-descr files.
Approved by: portmgr (tcberner)
Add WWW entries to port Makefiles
It has been common practice to have one or more URLs at the end of the
ports' pkg-descr files, one per line and prefixed with "WWW:". These
URLs should point at a project website or other relevant resources.
Access to these URLs required processing of the pkg-descr files, and
they have often become stale over time. If more than one such URL was
present in a pkg-descr file, only the first one was tarnsfered into
the port INDEX, but for many ports only the last line did contain the
port specific URL to further information.
There have been several proposals to make a project URL available as
a macro in the ports' Makefiles, over time.
(Only the first 15 lines of the commit message are shown above )
all: R eturn sobomax' ports to the pool
Commit bit of sobomax@ was safe-kept on 2018-12-03 by portmgr-secretary@
but somehow the ports were not reset. Reset all the ports except
net/ortp which has been exclusively requested by zirias@
Approved by: portmgr (blanket)
net/ortp: Fix build
- After net/bctoolbox has been upgraded most of the dependent ports are
broken
- Upgrade version 1.0.2=>5.1.32
- Switch MASTER_SITES to GL_SITES
- Switch LICENSE from GPLv2+ to GPLv3
Approved by: portmgr (blanket)
Relnotes: https://gitlab.linphone.org/BC/public/ortp/-/tags/5.1.32
Bump PORTREVISION for ports depending on the canonical version of GCC
as defined in Mk/bsd.default-versions.mk which has moved from GCC 8.3
to GCC 9.1 under most circumstances now after revision 507371.
This includes ports
- with USE_GCC=yes or USE_GCC=any,
- with USES=fortran,
- using Mk/bsd.octave.mk which in turn features USES=fortran, and
- with USES=compiler specifying openmp, nestedfct, c11, c++0x, c++11-lang,
c++11-lib, c++14-lang, c++17-lang, or gcc-c++11-lib
plus, everything INDEX-11 shows with a dependency on lang/gcc9 now.
PR: 238330
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake"
instead of "USES=cmake:outsource". Ports that fail to build
out of source now need to specify "USES=cmake:insource".
I tried to only set insource where explictely needed.
PR: 232038
Exp-run by: antoine
Bump PORTREVISION for ports depending on the canonical version of GCC
defined via Mk/bsd.default-versions.mk which has moved from GCC 7.4 t
GCC 8.2 under most circumstances.
This includes ports
- with USE_GCC=yes or USE_GCC=any,
- with USES=fortran,
- using Mk/bsd.octave.mk which in turn features USES=fortran, and
- with USES=compiler specifying openmp, nestedfct, c11, c++0x, c++11-lang,
c++11-lib, c++14-lang, c++17-lang, or gcc-c++11-lib
plus, as a double check, everything INDEX-11 showed depending on lang/gcc7.
PR: 231590
Update the Linphone stack and drop maintainership.
Linphone uses Qt5 now instead of GTK2.
audio/bcg729:
- switch to cmake, required by net/mediastreamer
- download distfile instead of using gitlab
- fix license: source code allows later GPL version
audio/msbcg729: deleted, net/mediastreamer contains a G.729 codec now
audio/msilbc: deleted, superseded by multimedia/mswebrtc
deskutils/belcard: version 1.0.2
multimedia/bcmatroska2: version 0.23
multimedia/msopenh264: version 1.2.1
multimedia/mswebrtc: version 1.1.1
multimedia/msx264: deleted, superseded by msopenh264
net/bctoolbox: version 0.6.0
net/belle-sip: version 1.6.3
net/liblinphone: version 3.12.0
net/linphone: version 4.1.1 + upstream Qt 5.11 patches
net/mediastreamer: version 2.16.1 + upstream libsrtp2 patch
net/ortp: version 1.0.2 + bump dependent port devel/libosmo-abis
security/bzrtp: version 1.0.6
textproc/belr: version 0.1.3
Most commonly used build systems support silent builds, when they
hide actual commands executed and only show short summary line (like
"CC foo.c"). CMake and ninja enable this by default, some autotools
using ports do as well. This is unacceptable because we need complete
build logs at any time, so we now switch to verbose build logs
unconditionally. Note that this change deliberately affects ALL
builds and not only package builds on cluster, because we need to
be sure that user experiencing failure can always provide informative
build log regardless of settings and without rerunning the build.
Change summary:
- Always do verbose builds for cmake, ninja and GNU configure (the
latter includes check if --disable-silent-rules is actually supported
by the configure script; there are isolated cases when it's not true)
(Only the first 15 lines of the commit message are shown above )
- Updates to the Linphone stack: Belle-sip 1.4.0, oRTP 0.24.1,
Mediastreamer 2.11.1, Linphone 3.8.1
- Switch to PolarSSL 1.3.x to enable instant messaging encryption
- SRTP/ZRTP support has been moved from oRTP to Mediastreamer
Notable enhancements in this release:
- Fullscreen mode
- Hang up button in the video window
- Wizard for audio/video settings
- Arabic translation
- Support RTP/AVPF (RFC4585) with VP8 codec: this feature allows
transmission error recovery for video, which greatly enhances the
video quality over unreliable links
- Move net/linphone-base to replace net/linphone and update to version 3.7.0
- Adjust ports that depended on linphone-base to depend on net/ortp or
net/mediastreamer instead
- Mark net-im/libjingle deprecated (part of Google Talk)
Approved by: portmgr (implicit, PORTREVISION bump of unstaged port)
Bump portrevision due to upgrade of devel/gettext.
The affected ports are the ones with gettext as a run-dependency
according to ports/INDEX-7 (5007 of them) and the ones with USE_GETTEXT
in Makefile (29 of them).
PR: ports/124340
Submitted by: edwin@
Approved by: portmgr (pav)
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the
old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in
exactly the same way as USE_AUTOTOOLS itself.
Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME
team -- all GNOME 2.12.x ports use it.
Preliminary documentation can be found at:
http://people.FreeBSD.org/~ade/autotools.txt
which is in the process of being SGMLized before introduction into the
Porters Handbook.
Light blue touch-paper. Run.
Apply a big libtool patch to allow porters to use the libtool installed by
the libtoolX ports instead of the one included with each port. Ports that
set USE_LIBTOOL_VER=X will now use the ports version of libtool instead of
the included version. To restore previous behavior, use the new macro,
USE_INC_LIBTOOL_VER. Both macros accept the same argument: a libtool version.
For example, to use the ports version of libtool-1.5, add the following to
your Makefile:
USE_LIBTOOL_VER= 15
To use the included version of libtool with extra hacks provided by
libtool-1.5, add the following to your Makefile:
USE_INC_LIBTOOL_VER= 15
With this change, ports that had to add additional libtool hacks to prevent
.la files from being installed or to fix certain threading issues can now
delete those hacks (after appropriate testing, of course).
PR: 63944
Based on work by:eik and marcus
Approved by: ade (autotools maintainer)
Tested by: kris on pointyhat
Bound to be hidden problems: You bet
Whoa there, boy, that's a mighty big commit y'all have there...
Begin autotools sanitization sequence by requiring ports to explicitly
specify which version of {libtool,autoconf,automake} they need, erasing
the concept of a "system default".
For ports-in-waiting:
USE_LIBTOOL=YES -> USE_LIBTOOL_VER=13
USE_AUTOCONF=YES -> USE_AUTOCONF_VER=213
USE_AUTOMAKE=YES -> USE_AUTOMAKE_VER=14
Ports attempting to use the old style system after June 1st 2004 will be
sorely disappointed.