Hurl is a command line tool that runs HTTP requests defined in a simple
plain text format. It can chain requests, capture values and evaluate
queries on headers and body response.
Hurl is very versatile: it can be used for fetching data, testing HTTP
sessions and testing XML / JSON APIs.
www/hurl: update 7.1.0 -> 8.0.1
Changelogs:
* https://github.com/Orange-OpenSource/hurl/releases/tag/8.0.0
* https://github.com/Orange-OpenSource/hurl/releases/tag/8.0.1
Major changes:
* Use CookieStore in HurlResult (crate compatibility)
* Delete deprecated --interactive option
* Replace legacy env var variable configuration HURL_foo by
HURL_VARIABLE_foo
* Rename ignore-asserts to no-assert
* Using new JSONPath module implementing RFC 9535
* Fix single quote in cookie value breaking curl output
* Add support for curl --data-raw option in hurlfmt import
* Fix truncating existing output file when response is tiny
www/hurl: mark hurl build broken for i386
Hurl build fails for i386 architectures due to mismatch error during
bindgen tests for libxml.
```
error[E0080]: evaluation of constant value failed
-->
/home/jc/rust-libxml/target/debug/build/libxml-0db722a43088e767/out/bindings.rs:407:29
|
407 | ["Size of __max_align_t"][::std::mem::size_of::<__max_align_t>() -
20usize];
|
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ attempt to compute `16_usize -
20_usize`, which would overflow
```
A GH issue reports[1][2][3] where created for this problem and for now the only
bypass
found was to disable the test. Which is wrong.
[1] https://github.com/Orange-OpenSource/hurl/issues/4400
[2] https://github.com/KWARC/rust-libxml/issues/186
[3] https://github.com/rust-lang/rust-bindgen/issues/3319
www/hurl: update to 6.0.0
Full changelog:
https://github.com/Orange-OpenSource/hurl/blob/master/CHANGELOG.md#6.0.0
Breaking changes:
* Check that variables do not conflict with existing functions
* Remove deprecated --fail-at-end option
* Change API for setting variable in hurl::runner::run
* Remove hurlfmt deprecated --format option
* Rename feature flag from vendored-openssl to static-openssl
www/hurl: update to 4.3.0
Full changelog: https://hurl.dev/blog/2024/04/24/announcing-hurl-4.3.0.html
Major changes:
* Export begin_call, end_call timings fields to RFC3339 (microseconds)
* Fix standalone css for regex
* Fix charset parsing logic of Content-Type header
* Fix filename templatization bug under certain conditions
* Fix empty glob not always returning an error
* Fix hurlfmt query certificate for hurl output format
* Fix --test progress bar not displayed when verbose is used
* Per request output takes file-root into account for path resolving
* Fix silent error when verbose option use unset variable
* Fix Content-type header override when used in lowercase
Security :
* Prevent script injection in HTML report
(can't be MFH, requires rust > 1.77.0)
Security:
https://github.com/Orange-OpenSource/hurl/security/advisories/GHSA-p4p2-ffh9-cc9c
www/hurl: update to 4.1.0
Breaking changes:
* Fix typo in option --path_as_is to --path-as-is
Major changes:
* Print host architecture with --version
* Add the aws-sigv4 option to generate AWS SigV4 signed requests
* Add --delay Option
* Support RFC-7807 application/problem+json for response body logging as
text
* Rename fail-at-end option with continue-on-error option
* Add connect-to per request option
* Add support for --resolve option per request
* Add TAP report
* Implement isDate predicate
Full changelog: https://github.com/Orange-OpenSource/hurl/releases/tag/4.1.0
www/hurl: Update to 4.0.0.
Major changes in 3.0.0
* major update because of breaking changes in Hurl crates
* Add test attributes to JUnit XML
* Add certificate query
* Add errors in HTML report
* Use long options for curl command
* Add date value/filters
* Implement isEmpty predicate
* Add curl input to hurlfmt
Bugfixes:
* Fix performance issue in Reader remaining method
* Parse empty JSON array body
* Add meta utf-8 charset to HTML report
(Only the first 15 lines of the commit message are shown above )
www/hurl: update to 2.0.0
Major changes:
* Support '-' in JSONPath dot notation
* Do not add newline at eof with --no-format option
* Fix variables update
* Fix querystring key parsing
* Add option ssl-no-revoke
* Add client cert/key to command line args and options
* Add connect-to option
* Add name attribute to JUnit report
* Check HTTP version and status first, then other asserts
* Support new one line string
* Add filters for htmlEscape and htmlUnescape
* Add toInt filter
* Use HTTP instead of HTTP/* for any HTTP version match
* Add RunnerOptionsBuilder to create instance of RunnerOptions
* Add support for LINK, UNLINK, PURGE, LOCK, UNLOCK, PROPFIND and VIEW HTTP
method
* Accept multiple --variables-file options
* Add GraphQL support
* Add --resolve option
Full changelog: https://github.com/Orange-OpenSource/hurl/releases/tag/2.0.0
www/hurl: New port, a command line tool that runs HTTP requests
Hurl is a command line tool that runs HTTP requests defined
in a simple plain text format.
It can chain requests, capture values and evaluate queries
on headers and body response. It can be used for fetching
data, testing HTTP sessions and testing XML / JSON APIs